// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^I specified a (?:(valid X estimation request)|(valid X cancel estimation)|(valid X accept estimation)|(valid X refuse estimation)|(valid Y estimation request)) JSON as body$").unwrap();
let string = "// Should match :
I specified a valid X estimation request JSON as body
I specified a valid X cancel estimation JSON as body
I specified a valid X accept estimation JSON as body
I specified a valid X refuse estimation JSON as body
I specified a valid Y estimation request JSON as body";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}