$re = '/^I specified a (?:(valid X estimation request)|(valid X cancel estimation)|(valid X accept estimation)|(valid X refuse estimation)|(valid Y estimation request)) JSON as body$/';
$str = '// Should match :
I specified a valid X estimation request JSON as body
I specified a valid X cancel estimation JSON as body
I specified a valid X accept estimation JSON as body
I specified a valid X refuse estimation JSON as body
I specified a valid Y estimation request JSON as body';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);