import Foundation
let pattern = #"^I specified a (?:(valid X estimation request)|(valid X cancel estimation)|(valid X accept estimation)|(valid X refuse estimation)|(valid Y estimation request)) JSON as body$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
// Should match :
I specified a valid X estimation request JSON as body
I specified a valid X cancel estimation JSON as body
I specified a valid X accept estimation JSON as body
I specified a valid X refuse estimation JSON as body
I specified a valid Y estimation request JSON as body
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}