#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^:\s;]+:-?\d+;)*$"
Local $sString = "白色:80;黑色:90;绿色:100;红色:-80;" & @CRLF & _
"" & @CRLF & _
"hello world" & @CRLF & _
"中文" & @CRLF & _
"飞翔吧" & @CRLF & _
"" & @CRLF & _
"白色:80;黑色:90;绿色:100;红色:-80;" & @CRLF & _
"" & @CRLF & _
"白色:80;绿色:100;红:-80;" & @CRLF & _
"" & @CRLF & _
"蛤蛤:-1;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")