$re = '/^([^:\s;]+:-?\d+;)*$/m';
$str = '白色:80;黑色:90;绿色:100;红色:-80;
hello world
中文
飞翔吧
白色:80;黑色:90;绿色:100;红色:-80;
白色:80;绿色:100;红:-80;
蛤蛤:-1;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);