import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^:\\s;]+:-?\\d+;)*$";
final String string = "白色:80;黑色:90;绿色:100;红色:-80;\n\n"
+ "hello world\n"
+ "中文\n"
+ "飞翔吧\n\n"
+ "白色:80;黑色:90;绿色:100;红色:-80;\n\n"
+ "白色:80;绿色:100;红:-80;\n\n"
+ "蛤蛤:-1;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}