const regex = /^([^:\s;]+:-?\d+;)*$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^:\\s;]+:-?\\d+;)*$', 'mg')
const str = `白色:80;黑色:90;绿色:100;红色:-80;
hello world
中文
飞翔吧
白色:80;黑色:90;绿色:100;红色:-80;
白色:80;绿色:100;红:-80;
蛤蛤:-1;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}