using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^:\s;]+:-?\d+;)*$";
string input = @"白色:80;黑色:90;绿色:100;红色:-80;
hello world
中文
飞翔吧
白色:80;黑色:90;绿色:100;红色:-80;
白色:80;绿色:100;红:-80;
蛤蛤:-1;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}