import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([^\\]]*)\\]";
final String string = "[This regex tester \n"
+ "evaluates JavaScript regular expressions]\n\n"
+ "[This regex tester evaluates JavaScript regular expressions]\n\n"
+ "[This regex tester \n"
+ "evaluates JavaScript \n"
+ "regular expressions]\n"
+ "s dflsf\n"
+ "sdf \n"
+ "sf\n\n\n"
+ "sflsjf\n"
+ "sjfslfj\n"
+ "sldkfj\n"
+ "lsdfj\n"
+ "f<br>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}