re = /\[([^\]]*)\]/
str = '[This regex tester
evaluates JavaScript regular expressions]
[This regex tester evaluates JavaScript regular expressions]
[This regex tester
evaluates JavaScript
regular expressions]
s dflsf
sdf
sf
sflsjf
sjfslfj
sldkfj
lsdfj
f<br>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end