# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:^title\s*=\s*"|\G) *)([^"\s\n]+)/$1{$2}/gm;t' <<< "title = \"What a interesting title foooooooooooo\",
title= \"What a boring title foo bar foo bar barfoo foobar\",
title=\"What a crazy bar foo title\","