use strict;
my $str = 'title = "What a interesting title foooooooooooo",
title= "What a boring title foo bar foo bar barfoo foobar",
title="What a crazy bar foo title",';
my $regex = qr/((?:^title\s*=\s*"|\G) *)([^"\s\n]+)/mp;
my $subst = '$1{$2}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";