import Foundation
let pattern = #"((?:^title\s*=\s*"|\G) *)([^"\s\n]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
title = "What a interesting title foooooooooooo",
title= "What a boring title foo bar foo bar barfoo foobar",
title="What a crazy bar foo title",
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1{$2}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)