$re = '/((?:^title\s*=\s*"|\G) *)([^"\s\n]+)/m';
$str = 'title = "What a interesting title foooooooooooo",
title= "What a boring title foo bar foo bar barfoo foobar",
title="What a crazy bar foo title",';
$subst = "$1{$2}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;