re = /((?:^title\s*=\s*"|\G) *)([^"\s\n]+)/m
str = 'title = "What a interesting title foooooooooooo",
title= "What a boring title foo bar foo bar barfoo foobar",
title="What a crazy bar foo title",'
subst = '$1{$2}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result