#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\[[\d]*,[\d]*,[\d]*\]*)"
Local $sString = "ls 0 " & @CRLF & _
"[0,86,180]" & @CRLF & _
"ls 1 " & @CRLF & _
"[1,2,200]" & @CRLF & _
"ls 2 " & @CRLF & _
"[2,3,180]" & @CRLF & _
"ls 3 " & @CRLF & _
"[3,4,234]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")