re = /(\[[\d]*,[\d]*,[\d]*\]*)/
str = 'ls 0
[0,86,180]
ls 1
[1,2,200]
ls 2
[2,3,180]
ls 3
[3,4,234]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end