package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[[\d]*,[\d]*,[\d]*\]*)`)
var str = `ls 0
[0,86,180]
ls 1
[1,2,200]
ls 2
[2,3,180]
ls 3
[3,4,234]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}