import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[[\\d]*,[\\d]*,[\\d]*\\]*)";
final String string = "ls 0 \n"
+ "[0,86,180]\n"
+ "ls 1 \n"
+ "[1,2,200]\n"
+ "ls 2 \n"
+ "[2,3,180]\n"
+ "ls 3 \n"
+ "[3,4,234]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}