const regex = /(\[[\d]*,[\d]*,[\d]*\]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[[\\d]*,[\\d]*,[\\d]*\\]*)', 'g')
const str = `ls 0
[0,86,180]
ls 1
[1,2,200]
ls 2
[2,3,180]
ls 3
[3,4,234]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}