#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^((?!error|empty).)*$)"
Local $sString = "varformals : PAR_OPEN PAR_CLOSE {}" & @CRLF & _
"| PAR_OPEN varform PAR_CLOSE {}" & @CRLF & _
"/* error / | error PAR_CLOSE {}" & @CRLF & _
"/ error / | error varform PAR_CLOSE {}" & @CRLF & _
"/ error */ | PAR_OPEN error PAR_CLOSE {}" & @CRLF & _
";"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")