import Foundation
let pattern = #"(^((?!error|empty).)*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
varformals : PAR_OPEN PAR_CLOSE {}
| PAR_OPEN varform PAR_CLOSE {}
/* error / | error PAR_CLOSE {}
/ error / | error varform PAR_CLOSE {}
/ error */ | PAR_OPEN error PAR_CLOSE {}
;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)