const regex = new RegExp('(^((?!error|empty).)*$)', 'gm')
const str = `varformals : PAR_OPEN PAR_CLOSE {}
| PAR_OPEN varform PAR_CLOSE {}
/* error / | error PAR_CLOSE {}
/ error / | error varform PAR_CLOSE {}
/ error */ | PAR_OPEN error PAR_CLOSE {}
;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}