re = /(^((?!error|empty).)*$)/m
str = 'varformals : PAR_OPEN PAR_CLOSE {}
| PAR_OPEN varform PAR_CLOSE {}
/* error / | error PAR_CLOSE {}
/ error / | error varform PAR_CLOSE {}
/ error */ | PAR_OPEN error PAR_CLOSE {}
;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end