#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(REPEAT)([\s\S]+?)(\s*)(.*)\n(.*)(UNTIL)(.*)"
Local $sString = " a = 1" & @CRLF & _
" REPEAT" & @CRLF & _
" OUTPUT a" & @CRLF & _
" a = a + 1" & @CRLF & _
" UNTIL a = 4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")