// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(REPEAT)([\s\S]+?)(\s*)(.*)\n(.*)(UNTIL)(.*)").unwrap();
let string = " a = 1
REPEAT
OUTPUT a
a = a + 1
UNTIL a = 4";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}