import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(REPEAT)([\\s\\S]+?)(\\s*)(.*)\\n(.*)(UNTIL)(.*)";
final String string = " a = 1\n"
+ " REPEAT\n"
+ " OUTPUT a\n"
+ " a = a + 1\n"
+ " UNTIL a = 4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}