re = /(REPEAT)([\s\S]+?)(\s*)(.*)\n(.*)(UNTIL)(.*)/m
str = ' a = 1
REPEAT
OUTPUT a
a = a + 1
UNTIL a = 4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end