$re = '/(REPEAT)([\s\S]+?)(\s*)(.*)\n(.*)(UNTIL)(.*)/m';
$str = ' a = 1
REPEAT
OUTPUT a
a = a + 1
UNTIL a = 4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);