package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\/\*\*[\s\S]*?@config\s*(\{[\s\S]*?\})[\s\S]*?\*\/\s*[\#\.]?([\w-]+)\s*(?:[\#\.]*([\w-]+)\s*)*{`)
var str = `Works all one one line..
/**
*
* Some ignored comments here...
* @config { name:'Orange Title (70pt)'}
*/
h1.title_orange {
}
Works on multiple lines, with extra lines in comment
/**
*
* Some ignored comments here...
* @config {
name:'Green Title (70pt)',
order:1
}
*/
div.green_title {
}
Workson multiple lines, with extra lines in comment
/**
* @config { name:'Blue Title (70pt)',
order:1 }
* comments coud be here
*
*/
span.blue {
}
THis doesnt work due to the mutliple classes..... Not sure what im going to do with this yet, probably just match the first one - I suppose we could have multiple @config attributes matched in order to the definitions, but that sounds very hard....
/**
* @config { name:'Blue Title (70pt)'}
*/
div.blue, div.bigBlue {
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}