import re
regex = re.compile(r"\/\*\*[\s\S]*?@config\s*(\{[\s\S]*?\})[\s\S]*?\*\/\s*[\#\.]?([\w-]+)\s*(?:[\#\.]*([\w-]+)\s*)*{", flags=re.IGNORECASE)
test_str = ("Works all one one line..\n\n"
"/**\n"
"* \n"
"* Some ignored comments here...\n"
"* @config { name:'Orange Title (70pt)'}\n"
"*/\n"
"h1.title_orange {\n\n"
"}\n\n\n"
"Works on multiple lines, with extra lines in comment\n\n"
"/**\n"
"* \n\n\n"
"* Some ignored comments here...\n"
"* @config {\n"
" name:'Green Title (70pt)', \n"
" order:1\n"
" }\n"
"*/\n"
"div.green_title {\n\n"
"}\n\n\n"
"Workson multiple lines, with extra lines in comment\n\n"
"/**\n"
"* @config { name:'Blue Title (70pt)', \n"
" order:1 }\n"
"* comments coud be here\n"
"*\n"
"*/\n"
"span.blue {\n\n"
"}\n\n\n"
"THis doesnt work due to the mutliple classes..... Not sure what im going to do with this yet, probably just match the first one - I suppose we could have multiple @config attributes matched in order to the definitions, but that sounds very hard....\n\n"
"/** \n"
" * @config { name:'Blue Title (70pt)'}\n"
" */\n"
"div.blue, div.bigBlue {\n\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")