use strict;
my $str = 'Works all one one line..
/**
*
* Some ignored comments here...
* @config { name:\'Orange Title (70pt)\'}
*/
h1.title_orange {
}
Works on multiple lines, with extra lines in comment
/**
*
* Some ignored comments here...
* @config {
name:\'Green Title (70pt)\',
order:1
}
*/
div.green_title {
}
Workson multiple lines, with extra lines in comment
/**
* @config { name:\'Blue Title (70pt)\',
order:1 }
* comments coud be here
*
*/
span.blue {
}
THis doesnt work due to the mutliple classes..... Not sure what im going to do with this yet, probably just match the first one - I suppose we could have multiple @config attributes matched in order to the definitions, but that sounds very hard....
/**
* @config { name:\'Blue Title (70pt)\'}
*/
div.blue, div.bigBlue {
}';
my $regex = qr/\/\*\*[\s\S]*?@config\s*(\{[\s\S]*?\})[\s\S]*?\*\/\s*[\#\.]?([\w-]+)\s*(?:[\#\.]*([\w-]+)\s*)*{/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}