const regex = /\/\*\*[\s\S]*?@config\s*(\{[\s\S]*?\})[\s\S]*?\*\/\s*[\#\.]?([\w-]+)\s*(?:[\#\.]*([\w-]+)\s*)*{/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\*\\*[\\s\\S]*?@config\\s*(\\{[\\s\\S]*?\\})[\\s\\S]*?\\*\\\/\\s*[\\#\\.]?([\\w-]+)\\s*(?:[\\#\\.]*([\\w-]+)\\s*)*{', 'gi')
const str = `Works all one one line..
/**
*
* Some ignored comments here...
* @config { name:'Orange Title (70pt)'}
*/
h1.title_orange {
}
Works on multiple lines, with extra lines in comment
/**
*
* Some ignored comments here...
* @config {
name:'Green Title (70pt)',
order:1
}
*/
div.green_title {
}
Workson multiple lines, with extra lines in comment
/**
* @config { name:'Blue Title (70pt)',
order:1 }
* comments coud be here
*
*/
span.blue {
}
THis doesnt work due to the mutliple classes..... Not sure what im going to do with this yet, probably just match the first one - I suppose we could have multiple @config attributes matched in order to the definitions, but that sounds very hard....
/**
* @config { name:'Blue Title (70pt)'}
*/
div.blue, div.bigBlue {
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}