#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)https:\/\/(?:(?:accounts|my)\.tase\.co\.il|maya\.tase\.co\.il\/(?:reports\/(?:mymessages|favorites)|account\/notification)|info\.tase\.co\.il\/Management\/GeneralPages\/Pages\/(?:PersonalFolder|Registration|Change_Password|UsersSearchIndex|Security%20Search)\.aspx).*"
Local $sString = "https://my.tase.co.il" & @CRLF & _
"https://accounts.tase.co.il" & @CRLF & _
"https://maya.tase.co.il/reports/mymessages" & @CRLF & _
"https://maya.tase.co.il/reports/favorites" & @CRLF & _
"https://maya.tase.co.il/account/notification" & @CRLF & _
"https://info.tase.co.il/Management/GeneralPages/Pages/PersonalFolder.aspx" & @CRLF & _
"https://info.tase.co.il/Management/GeneralPages/Pages/Registration.aspx" & @CRLF & _
"https://info.tase.co.il/Management/GeneralPages/Pages/Change_Password.aspx" & @CRLF & _
"https://info.tase.co.il/Management/GeneralPages/Pages/UsersSearchIndex.aspx" & @CRLF & _
"https://info.tase.co.il/Management/GeneralPages/Pages/Security%20Search.aspx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")