import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/(?:(?:accounts|my)\\.tase\\.co\\.il|maya\\.tase\\.co\\.il\\/(?:reports\\/(?:mymessages|favorites)|account\\/notification)|info\\.tase\\.co\\.il\\/Management\\/GeneralPages\\/Pages\\/(?:PersonalFolder|Registration|Change_Password|UsersSearchIndex|Security%20Search)\\.aspx).*";
final String string = "https://my.tase.co.il\n"
+ "https://accounts.tase.co.il\n"
+ "https://maya.tase.co.il/reports/mymessages\n"
+ "https://maya.tase.co.il/reports/favorites\n"
+ "https://maya.tase.co.il/account/notification\n"
+ "https://info.tase.co.il/Management/GeneralPages/Pages/PersonalFolder.aspx\n"
+ "https://info.tase.co.il/Management/GeneralPages/Pages/Registration.aspx\n"
+ "https://info.tase.co.il/Management/GeneralPages/Pages/Change_Password.aspx\n"
+ "https://info.tase.co.il/Management/GeneralPages/Pages/UsersSearchIndex.aspx\n"
+ "https://info.tase.co.il/Management/GeneralPages/Pages/Security%20Search.aspx";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}