using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/(?:(?:accounts|my)\.tase\.co\.il|maya\.tase\.co\.il\/(?:reports\/(?:mymessages|favorites)|account\/notification)|info\.tase\.co\.il\/Management\/GeneralPages\/Pages\/(?:PersonalFolder|Registration|Change_Password|UsersSearchIndex|Security%20Search)\.aspx).*";
string input = @"https://my.tase.co.il
https://accounts.tase.co.il
https://maya.tase.co.il/reports/mymessages
https://maya.tase.co.il/reports/favorites
https://maya.tase.co.il/account/notification
https://info.tase.co.il/Management/GeneralPages/Pages/PersonalFolder.aspx
https://info.tase.co.il/Management/GeneralPages/Pages/Registration.aspx
https://info.tase.co.il/Management/GeneralPages/Pages/Change_Password.aspx
https://info.tase.co.il/Management/GeneralPages/Pages/UsersSearchIndex.aspx
https://info.tase.co.il/Management/GeneralPages/Pages/Security%20Search.aspx";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}