using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^|]*)(\|())\|0\|?(\d[^|]*)\|([^|]*)\|([^|]*)\|([^|]*)$";
string input = @"WISEMAN·CINDY|0|29.98|THE·OZARK·FOOD·COOPERATIVE·EXCHANGE|9/30/2013·UT04·‐·Capital·Credit·Distributions|20464721";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}