package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([^|]*)(\|())\|0\|?(\d[^|]*)\|([^|]*)\|([^|]*)\|([^|]*)$`)
var str = `WISEMAN·CINDY|0|29.98|THE·OZARK·FOOD·COOPERATIVE·EXCHANGE|9/30/2013·UT04·‐·Capital·Credit·Distributions|20464721`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}