re = /^([^|]*)(\|())\|0\|?(\d[^|]*)\|([^|]*)\|([^|]*)\|([^|]*)$/
str = 'WISEMAN·CINDY|0|29.98|THE·OZARK·FOOD·COOPERATIVE·EXCHANGE|9/30/2013·UT04·‐·Capital·Credit·Distributions|20464721'
# Print the match result
str.match(re) do |match|
puts match.to_s
end