import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^|]*)(\\|())\\|0\\|?(\\d[^|]*)\\|([^|]*)\\|([^|]*)\\|([^|]*)$";
final String string = "WISEMAN·CINDY|0|29.98|THE·OZARK·FOOD·COOPERATIVE·EXCHANGE|9/30/2013·UT04·‐·Capital·Credit·Distributions|20464721";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}