$re = '/^([^|]*)(\|())\|0\|?(\d[^|]*)\|([^|]*)\|([^|]*)\|([^|]*)$/';
$str = 'WISEMAN·CINDY|0|29.98|THE·OZARK·FOOD·COOPERATIVE·EXCHANGE|9/30/2013·UT04·‐·Capital·Credit·Distributions|20464721';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);