# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^
(?:
.
(?=
.*+\n
(\1?+.)
.*+\n
(\2?+.)
.*+\n
(\3?+.)
)
)*?
...A.*+\n
\1?+
..A.*+\n
\2?+
.A.*+\n
\3?+
A//gmx;t' <<< "0000000
0000000
000A000
00AB000
AAAB000
ABBB000"