use strict;
my $str = '0000000
0000000
000A000
00AB000
AAAB000
ABBB000';
my $regex = qr/^
(?:
.
(?=
.*+\n
(\1?+.)
.*+\n
(\2?+.)
.*+\n
(\3?+.)
)
)*?
...A.*+\n
\1?+
..A.*+\n
\2?+
.A.*+\n
\3?+
A/mxp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";