$re = '/^
(?:
.
(?=
.*+\n
(\1?+.)
.*+\n
(\2?+.)
.*+\n
(\3?+.)
)
)*?
...A.*+\n
\1?+
..A.*+\n
\2?+
.A.*+\n
\3?+
A/mx';
$str = '0000000
0000000
000A000
00AB000
AAAB000
ABBB000';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;