import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ "(?:\n"
+ " .\n"
+ " (?=\n"
+ " .*+\\n\n"
+ " (\\1?+.)\n"
+ " .*+\\n\n"
+ " (\\2?+.)\n"
+ " .*+\\n\n"
+ " (\\3?+.)\n"
+ " )\n"
+ ")*?\n"
+ "...A.*+\\n\n"
+ "\\1?+\n"
+ "..A.*+\\n\n"
+ "\\2?+\n"
+ ".A.*+\\n\n"
+ "\\3?+\n"
+ "A";
final String string = "0000000\n"
+ "0000000\n"
+ "000A000\n"
+ "00AB000\n"
+ "AAAB000\n"
+ "ABBB000";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}