const regex = /^
(?:
.
(?=
.*+\n
(\1?+.)
.*+\n
(\2?+.)
.*+\n
(\3?+.)
)
)*?
...A.*+\n
\1?+
..A.*+\n
\2?+
.A.*+\n
\3?+
A/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^
(?:
.
(?=
.*+\\n
(\\1?+.)
.*+\\n
(\\2?+.)
.*+\\n
(\\3?+.)
)
)*?
...A.*+\\n
\\1?+
..A.*+\\n
\\2?+
.A.*+\\n
\\3?+
A', 'gm')
const str = `0000000
0000000
000A000
00AB000
AAAB000
ABBB000`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);