using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(?=(?:POST|GET|DELETE|PUT|PATCH|OPTIONS)\b)";
string input = @" edit_user_registration GET /users/edit(.:format) registrations#edit
PATCH /users(.:format) registrations#update";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}