const regex = /^\s*(?=(?:POST|GET|DELETE|PUT|PATCH|OPTIONS)\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(?=(?:POST|GET|DELETE|PUT|PATCH|OPTIONS)\\b)', 'gm')
const str = ` edit_user_registration GET /users/edit(.:format) registrations#edit
PATCH /users(.:format) registrations#update`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}