import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(?=(?:POST|GET|DELETE|PUT|PATCH|OPTIONS)\\b)";
final String string = " edit_user_registration GET /users/edit(.:format) registrations#edit\n"
+ " PATCH /users(.:format) registrations#update";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}