$re = '/^\s*(?=(?:POST|GET|DELETE|PUT|PATCH|OPTIONS)\b)/m';
$str = ' edit_user_registration GET /users/edit(.:format) registrations#edit
PATCH /users(.:format) registrations#update';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);